Bash checker v1.1 for smartnode on Ubuntu (If you already have a SmartNode Configured)



Bash Checker v1.1 for smartnode on Ubuntu 16.04 LTS x64

(!) No need to run this if you already used the official bash installer

ATTENTION: This installer is only suitable for a dedicated vps. The anti-ddos script in this installer will disable all ports including the http, https and dns ports.

This does not change the SSH port default

This is from the great work of

This script Assumes you already have a Smartnode installed. If you need to install a new Smartnode you may want to use the installer script provided by @msg786 or you can follow my guide at SmartCash SmartNode Setup Guide v2.1 (MAC Version) Quick Setup

You must run this script as smartadmin or ID you used to run smartcashd some people installed as root and that’s ok. At the end of the script you will be asked for a sudo password to run the anti-ddos script and reboot command

This shell script comes with 4 cronjobs:

  1. Make sure the daemon is always running:
  2. Make sure the daemon is never stuck:
  3. Make sure smartcash is always up-to-date:
  4. Clear the log file every other day:

And an anti-ddos script

  1. Disable all ports including the http, https and dns ports:

Login to your vps as smartadmin or ID you used to run smartcashd, donwload the file and then run it:

bash ./

At the end of the install your server will reboot so that the anti-ddos and cron jobs will take effect

Donation to my Smartcash please: SebFkuHrqDnj3obXvMtfxtQKRgFeVpXF5x


Hi @controllinghand,

will this do the same thing as the Stability part in the website? I couldn’t find the security part on, I am not sure how to whitelist the port in there but I saw on discord it’s not crucial? could you please let me know as I installed using the pdf guide? Thanks.


I’m not sure how you setup your smartnode. If you used the @msg768 then no need to do this. However, I did write a guide to enable the firewall and turn off root’s ability to ssh. Found here:


well that’s the thing… I used the guide pfd version 1(didn’t work), then version 1.1 (briefly), then version 1.2 haha… so that’s what I’m doing to all of them, is this correct?

mkdir ~/smartnode
cd ~/smartnode/
chmod 0700 ./
chmod 0700 ./
chmod 0700 ./
(crontab -l ; echo “/1 * * * * ~/smartnode/") | crontab -
(crontab -l ; echo "
/30 * * * * ~/smartnode/”) | crontab -
(crontab -l ; echo “0 0 */2 * * ~/smartnode/”) | crontab -
/etc/init.d/cron reload
smartcash-cli stop
pico ~/.smartcash/smartcash.conf
fallocate -l 4G /swapfile
chmod 600 /swapfile
mkswap /swapfile
swapon /swapfile
pico /etc/fstab
/swapfile none swap sw 0 0


can you jump on discord?

I can help you there. but have to leave in about 30 mins



Damn, sorry man, I was having lunch, just saw this now :frowning:


On firewall, add firewall group on

you can set rules for your firewall,

example: you can set a rule to accept only the port 9678,deny any others even the sshs.


Thanks, is that really necessary as I read on discord anyone can bypass that?


If you use the bash of this post,it does basically the same thing.

Its not necessary,but its recommended to hardened your SmartNode,will become faster and secure.

Smartnode - NEW_START_REQUIRED and other issues

Thanks for sharing, @controllinghand – great script!

I am still stuck and unable to make my smartnode start syncing up with the block index (displaying “blocks=0” and stuck in “PRE-ENABLED” as a result).

Any ideas what I am doing wrong? Thanks in advance.