Firewall Settings for Masternodes


#1

There seems to be a great deal of uncertainty going on around smartnode settings and actually get this thing running. The standard PDF instructions appear to be a bit confusing (or even containing mistakes), too.

** A GENERAL POST LISTING FIREWALL SETTINGS MIGHT BE HELPFUL FOR MANY HERE **
Could anyone share their experience, list what these settings need to be – that would be helpful for maybe all of us!

My own masternode isn’t syncing either, hence I am unable to get beyond “PRE-ENABLED” or “NEEDS TO RESTART” even though everything apperas to be set after double, triple, umpteenfold checks…

Could anyone please list their FIREWALL SETTINGS and state where the port 9678 settings need to be when using iptables specifically? Or whether there are any other tips?

smartcash-cli smartnode status throws:

“outpoint”: “COutPoint(0000000000000000000000000000000000000000000000000000000000000000, 4294967295)”,
“service”: “[::]:0”,
“status”: “Node just started, not yet activated”

and smartcash-cli getinfo shows “0 blocks” meaning blocks are not counting up, like so:

smartcash-cli getinfo
{
“version”: 1020800,
“protocolversion”: 90028,
“walletversion”: 130000,
“balance”: 0.00000000,
“blocks”: 0,
“timeoffset”: 0,
“connections”: 0,
“proxy”: “”,
“difficulty”: 0.000244140625,
“testnet”: false,
“keypoololdest”: 1620744816,
“keypoolsize”: 199,
“paytxfee”: 0.00000000,
“relayfee”: 0.00100000,
“errors”: “”

Any ideas? Thanks in advance, guys.