Infinite Block Processing Time after bootstrap


#1

Hi, I have been battling against the problem my QT wallet is facing to process the blocks after bootstrap; but to no avail. Any help is welcome. Thanks.


#2

The bootsrap was probably not done correctly.

You can follow this guide: https://smartcash.freshdesk.com/support/solutions/articles/35000027174-using-the-bootstrap-to-speedup-sync-process

What personally did to make the bootstrap work was:

1/Uninstalled the wallet.

2/Made 2 backups of my wallet.dat file

3/Deleted everything in my smartcash default folder

4/Downloaded this bootsrap https://smartcash.cc/txindexstrap.zip

5/Downloaded this smartcash.conf file template https://cdn.discordapp.com/attachments/383421643101437972/401770488562712576/smartcash.conf

(To clear out any possible suspicions about these links, they come from the official support page: https://smartcash.freshdesk.com/support/solutions/articles/35000027174-using-the-bootstrap-to-speedup-sync-when-upgrade-wallet24)

6/Put the Blocks and Chainstate folders of the txindexstrap.zip file in my default SmartCash folder

7/Put the smartcash.conf file template in in my default SmartCash folder

8/Copied one of my wallet.dat backups into my default smartcash folder

8/Started the wallet

The bootstraping phase was so fast I did not even had the time to see the numbers fly.
Then the wallet starts syncing, which should not be slow. If it is, add the following line:

maxconnections=1

to your smartcash.conf file.


#3

Thanks for your detailed step by step guide. Will try it out.


#4

Feel free to give us some feedback. :slight_smile:


#5

Will certainly do. Thanks :cowboy_hat_face:


#6

hi, I just tried to re-install as per your instructions; but the same problem returned i.e. processing blocks issue. Not sure which part I am doing wrong. Fyi, my wallet version is 1.1.1. I also added maxconnections=1 in smartcash.conf . I have bootstrapped other wallets before and it worked fine. Not sure why this is kinda complicated. Any feedback will be appreciated. Thanks