New smartnode install, blockchain syncing has stalled


I have a new server instance on Amazon’s EC2 with 20GB SSD. File install process went just fine. 10,000 smart collateral is in place. Wallet has started the smartnode and status says, PRE-ENABLED. However, the blockchain syncing process seems to have stalled on block 726380 and has been stuck there for two straight days. (At time of this writing, Smartcash Explorer shows the most recent block to be 833972.) Using puTTy, the “getinfo” report shows 8 network connections, but sync is apparently incomplete. I’ve tried restarting, but nothing has worked yet. Thanks for any help.


Try this to clear all blockdata and re sync from start (add sudo or su in case you don’t have right)
smartcash-cli stop; sleep 5 && rm -rf ~/.smartcash/{blocks,chainstate,rewards} && smartcashd


Since writing this, I’ve realized that my server had run out of memory causing the sync to stall/crash. I thought swapfile feature was enabled, but apparently not. I am now upgrading server to more memory, setting up swap disk, and re-installing fresh. Thanks for your help.