Not able to sync smartnode blocks


#1

Hi,

I get strange error after running smartnode server and synchronizing blocks:

This happens at the end of synchronization - I tried three times and each time in about the same place the same error occurred.

After this error when I try to start server again I get this message:
smartcashd: chain.cpp:96: CBlockIndex* CBlockIndex::GetAncestor(int): Assertion `pindexWalk->pprev’ failed.


#2

I got messages like this after this error occurred:

Please advise.


#3

Can you try

  1. stop wallet
  2. delete all file in data folder ( keep wallet.dat and all .conf file )
  3. start wallet
    wait until fully synced and see what happen

#4

I did that 3 times and the same error occurred. I managed to overcome this issue by downloading the blocks manually from https://smartcash.cc/txindexstrap.zip but right now I have another issue when I try to run the smartnode I get the message:
smartadmin@SmartNode01:~$ smartcash-cli smartnode status
{
“outpoint”: “COutPoint(0000000000000000000000000000000000000000000000000000000000000000, 4294967295)”,
“service”: “[::]:0”,
“status”: “Not capable smartnode: Can’t detect valid external address. Please consider using the externalip configuration option if problem persists. Make sure to use IPv4 address only.”
}

I guess that there is something wrong with my smartnode.conf file but I have entered the appropriate data - I have the same data in my wallet on my pc and everything seem to work fine besides the node is in PRE_ENABLED state.


#5

I have found the solution for that issue:

but there is another one after setting the externalip:

smartadmin@SmartNode01:~$ smartcash-cli smartnode status
{
“outpoint”: “COutPoint(0000000000000000000000000000000000000000000000000000000000000000, 4294967295)”,
“service”: “xx.xxx.xxx.xx:9678”,
“status”: “Not capable smartnode: Could not connect to xx.xxx.xxx.xx:9678”
}


#6

OK. I have fixed that. I had to open port 9678 on the firewall on my machine.