Not able to sync smartnode blocks



I get strange error after running smartnode server and synchronizing blocks:

This happens at the end of synchronization - I tried three times and each time in about the same place the same error occurred.

After this error when I try to start server again I get this message:
smartcashd: chain.cpp:96: CBlockIndex* CBlockIndex::GetAncestor(int): Assertion `pindexWalk->pprev’ failed.


I got messages like this after this error occurred:

Please advise.


Can you try

  1. stop wallet
  2. delete all file in data folder ( keep wallet.dat and all .conf file )
  3. start wallet
    wait until fully synced and see what happen


I did that 3 times and the same error occurred. I managed to overcome this issue by downloading the blocks manually from but right now I have another issue when I try to run the smartnode I get the message:
smartadmin@SmartNode01:~$ smartcash-cli smartnode status
“outpoint”: “COutPoint(0000000000000000000000000000000000000000000000000000000000000000, 4294967295)”,
“service”: “[::]:0”,
“status”: “Not capable smartnode: Can’t detect valid external address. Please consider using the externalip configuration option if problem persists. Make sure to use IPv4 address only.”

I guess that there is something wrong with my smartnode.conf file but I have entered the appropriate data - I have the same data in my wallet on my pc and everything seem to work fine besides the node is in PRE_ENABLED state.


I have found the solution for that issue:

but there is another one after setting the externalip:

smartadmin@SmartNode01:~$ smartcash-cli smartnode status
“outpoint”: “COutPoint(0000000000000000000000000000000000000000000000000000000000000000, 4294967295)”,
“service”: “”,
“status”: “Not capable smartnode: Could not connect to”


OK. I have fixed that. I had to open port 9678 on the firewall on my machine.


@pawellipowczan, I saw your post – thanks for sharing!

I wonder could you please list the firewall settings you used in order to illustrate what we need to do (or where I went wrong, it seems). I am having a very similar-looking problem where my masternode is not syncing with the block index (block count stays at “0”, not increasing…). It does not appear to be a Linux permissions problem, and I already ran the script – but you never know!

Any ideas what I can do?!

My masternode simply won’t sync, and I get the PRE-ENABLED or NEEDS RESTART messages in my local wallet as a result of this, apparently…

Any help would be fantastic, thanks in advance.