Restart Node / Update every week


#1

So I went seventeen days when the update took effect without receiving payment. Then after I did update the payments began again with some regularity ( Thank you,) However I have had to restart the node twice, once just before smart reward cycle, and another yesterday.

My question - Why do I need restart twice in two weeks? Can We limit updates, and restarts? Seems a vehicle to limit payouts.

Also, and I know the community can do nothing about this, but Into a node @ about 1500.00 that’s worth about 600.00 today, and each node payment as shown in block folio for the duration has decreased in value. Do the Developers not understand this must be a common experience. Some show of understanding from the developers towards node holders in this light should be expected. Some kind of (Pep Talk,) At least in Lou of real action, which should be the priority.

My feeling is Smart cash is not concerned with viability of the node holding community, but are we not all the same community, do we not all need viability to continue? Dose it not benefit the community if the network thrives, and do you not need viability to thrive? I may be wrong to assume this but Smart cash price should be a consideration. I’m not seeing that.

Thank you!


#3

We have dedicated support folks just for this. There is a place to get help, and it’s quite easy to set up. This is necessary because often you need to provide information and do things, back and forth, so a forum doesn’t work well. You can do that here: http://discord.smartcash.cc there is a #smartnodes channel.

However. You don’t need to update frequently. You really only need to do one thing and that is set it up correctly to begin with. You can even have a hosting company like NodeSupply do that for you. Pick from the hosts here: https://smartcash.cc/smartnodes/#smarthosting

One thing to do to set it up correctly is to enable swap space: Make you sure you have about 4 GB additional space to spare on your VPS.
Connect to your VPS with root credentials and run the following commands:
fallocate -l 4G /swapfile

chmod 600 /swapfile

mkswap /swapfile

swapon /swapfile

Open pico /etc/fstab and add the following line at the end of the file (press tab to separate each word/number):
/swapfile none swap sw 0 0

Finally reboot your server, a 4 GB sized swap file should have been created.

Also, make sure you update to the latest version smartcashd with this:

sudo apt update && sudo apt install smartcashd -y
smartcash-cli stop
smartcashd

Hopefully that helps. If you need more help please jump in a chat room with us.

30 minute reply isn’t so bad, right?