SmartCash SmartNode SetUp Guide


#23

Problem solved, thanks everyone on the Discord and forums :smiley:

Thank you so much for the guide. I am cutting it close to setting up before the 300k block but I need assistance.

I am on Section 8, step 7 and wen I input " ./smartcash-cli smartnode status" I receive…

-bash: ./smartcash-cli: No such file or directory.

If you can please advise on how to resolve this issue so I may set up the node.

Thank you.


#24

you seem to be in the wrong directory.

To check your current directory you can use “pwd”


#26

Hello J.Smart/fluffy cat,
I am on Section 8, step 7 and wen I input " ./smartcash-cli smartnode status"

I am getting same error as yours

-bash: ./smartcash-cli: No such file or directory.

what to do next. I checked the current directory. what directory should I be in?


#27

Have you tried using just

smartcash-cli smartnode status


#28

can I use the same VPS I am using to run on a different masternode? or do I need a brand new one for each masternode?


#29

Nodes provide the functionality of the network. The more distributed they are - the better for different users. Although there are tricks for hosting two or more nodes on one server, it creates a single point of failure and that is not good for the network in general. So think of one node = one server. There are many VPS providers out there.


#30

okay. what are the possibilities of failure for hosting different network of masternodes on one vps?


#31

Went through the setup guide but can’t start my node, it remains in status PRE_ENABLED. Serverside status says ‘Not capable smartnode: Invalid protocol version’. Anyone a tip what might be wrong?


#32

Thank you, this will be very useful.


#33

Hello,

I have gone through the install and when I do the command “smartcash-cli getinfo” the response is “error: couldn’t connect to server”. I have logged out and then back in, repeated the command and get the same response. Plus, in the wallet I seems to be stuck at PRE_ENABLED.

I did check the current directory using “pwd” and the output is “/root” “root@vultr:~# ^C”

I also did the command “smartcash-cli smartnode status” and the output is also “error: couldn’t connect to server”.

Please advise how can I fix the issue.

WH


#34

If you get this error message it means that your SmartNode isn’t running anymore. Try to restart it with smartcashd, it will reinitialize and then you should be able check your Smartnode status with smartcash-cli smartnode status. If the status says “Not capable smartnode: Smartnode not in smartnode list” then you will have to start alias your node via your wallet.

To prevent further crashes and to always keep your SmartNode running, I would sugguest to add cronjobs as described in the SmartNode Hardening guide.


#35

Hello nflaw and thank you for the response.

This is what I have done:

In PuTTY while being logged into the VPS I entered:
smartcashd

Response:
Smartcash server starting
root@vultr:~# Error: Cannot obtain a lock on data directory /root/.smartcash. Smartcash is probably already running.

Then I tried:

smartcash-cli smartnode status

Which gave the response:
error: couldn’t connect to server

I did go back to my wallet and did the start alias command which did not change the results of the commands provided.

Sorry for the trouble on this as I am a novice at this sort of thing, I do appreciate any assistance.

WH


#36

Okay, when it’s stuck like that, you have to stop the smartcash process with smartcash-cli stop and then try restaring it with smartcashd.

If it still gives you the “Cannot obtain a lock on data directory” error, you have to delete the .lock file in the SmartCash directory using the command: rm ~/.smartcash/.lock and try to restart it after that.

But I guess there’s another configuration problem underlying your issue. So you should check your debug.log in the .smartcash directory for any odd signs with cat ~/.smartcash/debug.log.

For a more interactive assistance on SmartNodes related problems I would suggest that you join the SmartCash discord and ask in the #smartnodes channel. Alternatively, you can also get direct help on the SmartCash Telegram channel.

And don’t worry, we all started somewhere.


#37

Hi nflaw,

I did exactly what you instructed and did the command smartcash-cli stop

Then I did the command smartcashd and it did not work.

Next I did the command rm ~/.smartcash/.lock

Then cat ~/.smartcash/debug.log

Which gave the response:

Smartcash server starting
root@vultr:~# Error: Unable to bind to 0.0.0.0:9678 on this computer. Smartcash is probably already running.
Error: Failed to listen on any port. Use -listen=0 if you want this.

Should i just delete it all and try again? If so, how would I delete the install that is on the VPS to try it again, this is really frustrating, I am just trying to be a contributor to the network…

Thank you for your help.

BTW I did set up on Discord and I have not been able to get a resolution there.


#38

Hi JustBecasue did you get your problem resolved? If not please look me up in discord or respond here.


#39

Yes, all good now.

Will be doing more once I see some remittances.

Thank you for the help.


#40

Great work! Thank you.