Smartcash wallet issue


#1

I am getting an issue while assessing my Smart Cash wallet which says error initializing wallet database environment. I just updated my smartcash wallet to 1.0.1. How can i solve this issue. Please help.


#2

close wallet

Navigate to here

C:\Users\User\AppData\Roaming\smartcash

delete all the files from the wallet except the wallet.dat file

http://proteanx.com/bootstrap.zip

Download bootstrap and exact file into this location where your wallet file is.

Open wallet again see how you go.


#3

I restarted the computer and the wallet opened, but which i closed the wallet again it now gives the same error. I don’t know what to do. Should i restart again and backup the Private keys?


#4
  1. Always backup private keys

  2. why did you restart computer ?


#5

I restarted coz i thought it might work and it did. I am an Hardware engineer and I think there is a bug with Wallet 1.0.1 Which doesn’t allow you to close the wallet and open it back again. It needs a restart. I restarted again and it works but only for the first time.


#6

I have the same wallet version just closed and re-opened again no issues for me there is no bug did you extract the bootstrap ?


#7

I am afraid to extract any file provided on the internet with the wallet file. I hope you understand.


#8

that file is from the dev team


#9

Will check it out on a dummy wallet. Thx for the help.


#10

Hi Somnium,

Thanks for the tip. Can you please confirm that I delete ALL files in the AppData/Roaming/Smartcash folder? So essentially all that should remain would be the wallet.dat file and then the bootstrap folder which I would have downloaded.

Sorry for the newbie question, just getting the hang of it and like any rookie I am afraid to delete something that I don’t know what it is.

Thanks in advance for your help.

Tommy


#11

That is the correct method


#12

I did exactly that and it worked a treat,

Thanks!


#13

If you use the bootstrap does it still revalidate every past transaction?


#15

Thank you for suggesting this method. It’s work.