Smartnode setup Help


#1

After Sec.9 Step 2.
I open my window smartcash wallet. It never open but says

" Enabling Smartnode support requires turning on transection indexing.Please add txidex=1 to your configaration and start with -reindex.

What l suppose to do to open my wallet set smartnode.
Please Help! Thanks.


#2

Hi please DM me on discord


#3

Hello Somnium,Thanks for your reply, Im not very good in computer but I tried to setup my first master/smartnode using the Guideline but l have problem with smartcash window wallet Can please help me to settle this problem.Secondly l dont know how to contect you from discord.
Thanks


#4

#5

Hello Somnium,

l solve the pboblem and my node is running. Thanks for reply that willing to help me. l will learn discord, contact you later. Thanks again.


#6

Glad to hear its working all the best.


#7

Hello Somnium, the sync of my Mac wallet, is taking forever. do you have by chance a link where i can download the blockchain?

PS: I cannot get the verification in Discord, so i cannot DM you there…

Thanks


#8

Hi!

On some rigs, syncing takes a long time. The first tip to solve it is:

Add the following line to your smartcash.conf file: maxconnections=1
(You can also use: maxconnections=2)
It sounds paradoxical, but it makes the system more stable and allows to sync faster.

Otherwise, you can find a bootstrap (with a tutorial on how to use it) here: https://smartcash.freshdesk.com/support/solutions/articles/35000032541-how-to-upgrade-to-smartcash-wallet-v1-1-1-smartnode-mandatory-


#9

Karl HI!

Your answer is much appreciated!

I am a super noob, sorry for the further question.

Regarding your advice to add maxconnections=1 I am not sure where to add it exactly.

In fact the smartcash.conf I download from the guide you give me looks like this:

rpcuser=LOCALUSERNAME
rpcpassword=LOCALPASSWORD
txindex=1

While the smartcash.conf in my smartcash data folder looks like this:

# Smartnode config file
**# Format: alias IP:port smartnodeprivkey collateral_output_txid collateral_output_index **
# Example: sn1 127.0.0.2:9678 93XXXXXL8Xg 2bXXXXa67c 0

I add some XXX just for privacy reasons…

How and where should i add maxconnections=1 and txindex=1 …?

I tried also option 2.
after downloading the whole chain and blocks, in installing in the data folder I got an error:

34

If I select ok, I will start the whole download process again from week 36…

Thanks again for the patience…

Pepper


#10

Happy to help! :slight_smile:

There is a** smartcash.conf** file and a smartnode.conf file. The line I advised you to add is to put in the smartcash.conf file, the lines you posted are the ones that have to be in the smartnode.conf file.

If you don’t have any smartcash.conf file in your data folder, just copy the one you downloaded, then add the maxconnections=1 line. Your file should look like this:

rpcuser=LOCALUSERNAME
rpcpassword=LOCALPASSWORD
txindex=1
maxconnections=1

If you run your wallet, it should start syncing faster.

You got the “You need to rebuild…” message because you probably did not have a smartcash.conf file in your data folder.


#11

Great Karl,

It all worked fine.

thanks a bunch.


#12

Thanks for the feedback! :slight_smile: