Smartnode Setup Issues


#21

its more easy to setup VPS


#22

I’m an admitted noob, soo. I really screwed up, and hope someone can help. I made it through the set up fine, but …
so I used the you tube guide she shows you have to put in

txindex=1

into smartcash config file, well it wasn’t there, just the smartnode config file, and no one said you have to create it…this is where the noob thing comes in…i should have known
but I thought well this is the new 1.1.1 and maybe its changed since she posted the video.

so I went through all well except it now says I have to add txindex=1 to a config file that doesn’t exist, and it says then start with reindex.

my wallet wont open, I get that message. please troll forth, I deserve a little…lol, but if anyone can help starting with creating a smartcash.conf file properly–I’ve tried, but seems not to help.
and then how do I reindex if the wallet wont open?

thank you


#23

Can you read the guide here https://smartcash.freshdesk.com/support/solutions/articles/35000044334-smartnode-setup-guide-cold-setup-


#24

Hello everyone,
I have been struggeling with setting up my smartnode now for about 3 days, if anyone could help me I will really appreciate it!

So the main issue is that after setting everything up I can’t start my node. Everything is synchronized and I keep getting “status”: “Not capable smartnode: Smartnode not in smartnode list” on my VPS side after command “smartcash-cli smartnode status”.

When I try to start the node in “SmartNodes” tab with “Start MISSING” button I receive message box that 0 nodes were added. Also starting alias does not help.

Also I get different statuses on my local machine like : “MISSING”, “EXPIRED”, “PRE_ENABLED”, “NEW_START_REQUIRED” but on my VPS I keep getting “status”: “Not capable smartnode: Smartnode not in smartnode list” and it appears to be the true status.

I have been trying to edit both smartcash.conf on the VPS and on local machine. Adding txindex=1 on both, even matching rpcuser and rpcpassword on both and nothing helps.

Thanks in advance!


#25

Can you try again from scratch with this guide https://smartcash.freshdesk.com/support/solutions/articles/35000047674-guide-to-creating-a-smartcash-smartnode-vps-in-10-minutes-with-vultr
i sure it will work


#26

Thank you for fast reaction, although I would appreciate some specific troubleshooting advice since I fallowed every guideline already and have not found solution for my problem.

Maybe that getinfo screen helps:
getinfo


#27

Hi,

  1. make sure you send exactly 10K smartcash in 1 transaction
  2. make sure smartnode genkey are the same in smartnode.conf in desktop wallet and smartcash.conf in your vps

#28

Problem solved, thanks anyway